Pay in 4 interest-free payments of $375.00 Learn more
Shipping Estimate
USA
- USA
- CAN
- USA
- CAN
Ships within 48 hours · Estimated delivery Oct 3 - Oct 8
Pay in 4 interest-free payments of $375.00 Learn more
Ships within 48 hours · Estimated delivery Oct 3 - Oct 8
reducing maintenance time and operational costs
1 (supports 4K@120Hz Card Dimensions 305 mm x 120 mm x 42 mm DirectX Support Version 12 API OpenGL Support Version 4
Product description SPECIFICATIONS Rated Output Power 1000W Form Factor ATX 80 PLUS Certification Titanium Input Voltage 100-240V
1542 BootPRFC 1058 Routing Information ProtocolRFC 1112 IGMP v1RFC 1122 Host requirementsRFC 1256 IPv4 ICMP Router Discovery (IRDP)RFC 1492 TACACS+RFC 1519 Classless Interdomain Routing (CIDR)RFC 1587 OSPF not-so-stubby area (NSSA) OptionRFC 1591 Domain Name System (DNS)RFC 1812 Requirements for IP Version 4 routersRFC 2030 SNTP
and ideal for businesses requiring on-demand label printing
b r automation 5pc725 1505 k03 5p62 khs 07 24vdc 1 2 5a rev h0 nsnp o1amp reducing maintenance time and operationalThe B&R 5PC725. 1505 K03 is a genuine display module. Supplied New Surplus without the original packaging (NSNP). Manufacturer: B&R MPN: 5PC725. 1505 K03 Type: Display module Specifications: 24VDC, 1 2. 5A, REV. H0 Condition: NSNP New Surplus No Package Shipped worldwide DDP all duties, taxes and broker fees included. Purchase Orders accepted.
US$ 210.00
US$ 160.00
US$ 487.50
US$ 360.00
US$ 265.00
US$ 160.00
US$ 178.50
US$ 508.00
US$ 478.50
US$ 160.00
US$ 102.00
US$ 178.50
US$ 270.50